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About This Book

This book of the Microsoft® TV Help system describes the Microsoft TV Simulator graphical user interface for Microsoft TV, which is the client side of the Microsoft TV platform. The Microsoft TV Simulator lets you test Microsoft TV applications and view how they look and behave when run on a Microsoft TV-based set-top box.

Organization of This Book

This book is organized as follows:

	Section
	Description

	About the Microsoft TV Simulator
	Introduces the Microsoft TV Simulator.

	Before You Begin
	Provides information about requirements that must be met before you can use the Microsoft TV Simulator. It also provides instructions for installing the Simulator software.

	Configuring the Simulator
	Describes how to configure the Simulator to behave in the same way as the Microsoft TV-based set-top boxes on which you plan to deploy your applications.

	Installing Your Applications
	Describes how to prepare your applications for testing with the Simulator.

	Accessing Simulator Commands
	Describes how to navigate the Simulator with its on-screen controls.

	Testing Browser Menu Options
	Describes how to navigate the Simulator with its menu commands.

	Managing Files
	Describes how to open and save local files, and how to copy content from the Simulator.

	Selecting Frequently Used URLs
	Describes how to manage the links in the Simulato’sr Favorites menu.

	Simulating Interactive TV links
	Describes how to simulate Advanced Television Enhancement Forum (ATVEF) content. 

	Debugging Your Application
	Describes how to track Microsoft TV JScript messages for debugging purposes.


Other Documentation

For a description of the documentation available with Microsoft TV, see the Overview of Documentation at the beginning of the Microsoft TV Help system.

About the Microsoft TV Simulator XE "Microsoft TV Simulator:overview" 
The Microsoft® TV Simulator (Simulator) tests application developers’  ActiveX controls and native applications without an actual set-top box. This tool provides a full user interface, including separate dialog boxes for:

· Testing an interactive TV link

· Testing batched interactive TV links

· Viewing visited HTML pages 

· Checking HTML elements on a page

· Viewing debug messages

· Checking gamma correction

It also provides a virtual remote control for testing how your application responds to remote control instructions. 

The Microsoft TV Simulator simulates the behavior of the Microsoft TV Browser, its built-in user interface components, the standard Microsoft TV applications, and your own custom applications. 

By using the Simulator you can customize and test the standard UI and add your own applications on a Windows NT system instead of installing them on a Microsoft TV-based set-top box.

Before You Begin XE "Simulator:installation requirements" 
Before using the Microsoft® TV Simulator, familiarize yourself with the following information: 

· System Requirements
· Application Requirements
· Installing the Microsoft TV Simulator
System Requirements XE "Simulator:system requirements" 
Before you install Microsoft TV Simulator software onto a development workstation, the workstation must meet the following criteria: 

· PC with Pentium Class processor; Pentium 90 MHz or higher processor recommended

· Windows NT 4.0, with Service Pack 3 (SP3) or above  

· 24MB of RAM; 64MB recommended

· DirectDraw-compatible video card capable of 16-bit processing. 

Note   The Simulator only supports TVControl-enabled HTML content on Windows 2000 systems equipped with ATI All In Wonder graphics cards. Systems equipped with any other series of graphics card or Window NT display a photograph of a beach in any page that includes a TV Control. 

· Internet connection for access to a service. 

Note   Microsoft provides a test service known as GENPAK for Microsoft TV developers. Developers can access GENPAK from the Internet.

· CD-ROM drive compatible with the multimedia PC specification

· 800x600 or higher-resolution monitor; 1024x768 or higher, recommended

· Microsoft Mouse or compatible pointing device

Application Requirements XE "Simulator:application: requirements" 
The application you want to test using the Microsoft TV Simulator must meet the following criteria:

· COM object created (preferably) through Visual C++

· Compiled for Windows NT

Note   After you have completed your testing, you must compile the application as a Windows CE COM object before you can load it onto the target set-top box.

Installing the Microsoft TV Simulator XE "Simulator: installing" 

 XE "installing Microsoft TV Simulator" 
The Microsoft TV Simulator provides an install wizard to make installation easy. 

To install the Microsoft TV Simulator

1. Insert the Microsoft TV Software CD.

2. Launch the setup.exe program located in the OEM Simulator directory of the CD.

3. Do one of the following:

· Click Next to move forward to the next Setup dialog box

· Click Back to return to the previous Setup dialog box

· Click Cancel to close the Setup program without installing Platform Builder.

4. At the Ready to Install dialog box, click Next to begin the installation. Files are copied onto the target drive.

5.  A message appears indicating that installation is complete. 

6. Click Finish.

You are now ready to integrate your application into the Microsoft TV Simulator software. 

Configuring the Simulator XE "configuring the Simulator" 

 XE "Simulator: configuring" 
This section describes how to configure the Simulator to behave in the same way as the Microsoft® TV-based set-top boxes on which you plan to deploy your applications. It contains the following sections:

	Section
	Description

	Configuring the Browser Display
	Describes how to configure how the Simulator renders content.

	Specifying the User-Agent String
	Describes how to specify the information that the Simulator sends in the User-Agent field of HTTP request headers. 

	Specifying the Accept-Language String
	Describes how to specify the information that the Simulator sends in the Accept-Language field of HTTP request headers.

	Specifying Private Headers
	Describes how to add custom headers that the Simulator includes in HTTP request headers..

	Configuring Data Downloads
	Describes how to test applications for data downloads.

	Configuring Message Watch Notification 
	Describes how to configure the Simulator to simulate set-top box "message waiting" indicators.

	Defining the Default Service
	Describes how to define the service to which the Simulator connects when you click on Use MSTV Server from the Service Options page.

	Specifying User Interface Content Directories
	Describes how to use custom user interface files in conjunction with the default user interface.

	Translating Partition Names
	Describes how to configure the Simulator for custom application partitions.

	Installing Your Applications
	Describes how to integrate custom applications into the default user interface.


Configuring the Browser Display XE "browser: configuring display" 

 XE "configuring: browser display" 
You can configure how the Browser displays information in the Microsoft TV Simulator by adjusting the Gamma correction and selecting the appropriate screen format.

Adjusting Gamma Correction XE "gamma correction" 

 XE "adjusting gamma correction" 
You can calibrate the color on the Simulator to match the Gamma correction applied to your TV. 

Tip   If the Simulator is running slowly, turn off Gamma correction to improve performance. 

To adjust Gamma correction

7. Select Gamma Correction from the Tools->Display menu.

The Adjust Gamma dialog box appears:
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8. Enable or disable global Gamma correction.

If you enable global Gamma correction, you can adjust the brightness. If you disable global Gamma you cannot adjust the brightness. 

9. Drag the slider until the contents of the Browser Window meet your requirements.

Tip   Use the Gamma correction to match the color and brightness of the image in the Browser Window with the image displayed on the TV.

10. Click OK.

The value is saved and applied to your application, either globally or to the specific contents currently displayed in the Browser Window.

Configuring the Display Format XE "display format" 

 XE "testing: display format" 
The Simulator can render content in a variety of display dimensions. If you have custom content that is formatted specifically for PAL screens, you can configure the Simulator to present the content in the appropriate display area. 

To configure the Simulator display for a specific display format:

11. Choose Configuration… from the Tools menu. The display configuration dialog appears:
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12. Choose the desired display type from the pull-down menu. The Simulator supports the following standard screen dimensions:

	Format
	Screen Size
	Safe Display Area

	NTSC 
	640x480
	560x420

	NTSC Wide Screen
	854x480
	748x420

	PAL
	768x576
	672x504

	PAL Wide Screen
	1024x576
	896x504


13. To test content on with non-standard display, edit the Width and Height fields. The Display Configuration name automatically changes to “Custom.”

The Browser Window displays the picture from your application according to the standard you specify. NTSC is the default video standard applied to the Browser content. You can switch between the standards in the Simulator.

Specifying the User-Agent String XE "User-Agent string" 

 XE "testing: User-Agent string" 
The Simulator lets you define the string that it sends in the HTTP header field, User Agent. This header indicates the specific version of the browser that is requesting the Web page and the operating system it is running under. For details on the User-Agent header field, see RFC-2616, Hypertext Transfer Protocol.

To specify the User Agent String:

14. Select Set User Agent from the Tools->Browser menu.

The following dialog box appears:
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15. Enter a new user agent string.

16. Click OK.

Specifying the Accept-Language String XE "Accept-Language string" 

 XE "testing: Accept-Language string" 
The Simulator lets you define the string that it sends in the HTTP header, Accept-Language. This header indicates the user’s country and language in all HTTP requests. This header helps servers respond with content customized for the specified language and country. For details on the User-Agent header field, see RFC-2616, Hypertext Transfer Protocol.

To specify the Accept-Language string:

17. Select Set Accept-Language from the Tools-> Browser menu.

The following dialog box appears:
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18. To add an entry to the Accept-Language list:

a. Choose the language from the Language menu.

b. Choose the country from the Country menu.

c. Click Add.

19. To change the order of entries in the Accept-Language list:

d. Choose the Accept-Language list entry that you want to move up or down in the list.

e. Click Move Up or Move Down to change the selected entry’s position in the list.

20. To remove an existing Accept-Language list entry:

f. Select the entry you want to remove in the Accept-Language list.

g. Click Remove.

21. When the Accept-Language list contains the entries, click Close.

Specifying Private Headers XE "HTTP headers:specifying private headers" 

 XE "specifying private headers" 
The Simulator lets you define custom HTTP headers that conform to the header field format described RFC-2616, Hypertext Transfer Protocol. You can use private headers to accommodate services that accept unique data in HTTP headers.

To specify a private header:

22. Select Set Private Header from the Tools-> Browser menu.

The following dialog box appears:
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23. To add a header and corresponding value to the list of private headers:

h. Enter a unique header name in the Header Name field.

i. Enter the corresponding value in the Header Value field.

j. Click Add.

24. To modify an existing header:

k. Select the header you want to modify in the Header List list.

l. Edit the Header Name and Header Value fields.

m. Click Change.

25. To remove an existing header:

n. Select the header you want to remove in the Header List list.

o. Click Remove.

26. When the Header List contains the desired headers, click OK.

Configuring Data Downloads XE "downloads" 

 XE "data downloads" 

 XE "testing: data downloads" 
You can test whether your application correctly performs data downloads. A program listing is an example of a typical data download that your application would need to be able to process. OEMs who develop services are the primary users of this data download function. 

Note   Downloads most commonly occur at night.

To test data downloads

27. Make sure that Auto Power-On is disabled.

· Uncheck Auto Power-On from the Tools->Hardware menu

· Exit the application 

· Restart the application

Tip   With the power off, the Browser Window is blank.

28. Select Power-On (Data Download) from the Tools->Hardware menu.

29. Verify that your application connected to the service.

30. Confirm that the service downloaded the data you expected. 

A TV Listing is an example of a data download that a service performs. 

Note   During the data download, a message appears indicating that a download is in progress.

When the data download completes, the Simulator exits and restarts automatically.

Configuring Message Watch Notification XE "message watch notification" 

 XE "testing: message watch notification" 
The message watch notification feature indicates that a message is waiting. In a real environment, a waiting message should cause the Messages LED on the set-top box to be enabled. However, since this is a simulated environment, no test is currently available for enabling a virtual Messages LED on the set-top box. However, you can go to the mail application to confirm that the service has sent a notification.

To test message notification

31. Make sure that Auto Power-On is disabled.

· Uncheck Auto Power-On from the Tools->Hardware menu

· Exit the application 

· Restart the application

Tip   With the power off, the Browser Window is blank.

32. Select Power-On (Message Watch) from the Tools->Hardware menu.

33. Verify that your application connected to the service.

34. Confirm that a message is waiting. 

You can look at the mail application to confirm that the service has sent a notification.When the message notification completes, the Simulator exits and restarts automatically.

Defining the Services XE "default service" 

 XE "defining: default service" 
The Simulator connects to a service defined in the Configuration file, Configuration.xml when it starts up. Although you can test the Simulator with other services by creating an alternative version of the Configuration file, you would also have to add it to the BrowserData list and then restart the Simulator before you could test the results. 

A simpler way to test the Simulator is to define additional services with which you want through the Simulator’s Service menu. 

To define a custom service

35. Click the Custom Service option from the Service menu.

The following dialog box appears:
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36. Enter the name of the service in the Menu Name field as you want it to appear in the Service menu.

Use a name that easily identifies the custom service. It can be up to 32 characters in length.

37. Enter the hostname-port combination that is to be used for accessing the service.

38. Enter the IP address of the Name Server to use for name look-ups.

39. Click OK.

40. Choose the Service from the Service menu to use the service you just finished defining. The Simulator resets automatically and connects to the new service.

Specifying User Interface Content Directories XE "Browser Data: specifying location" 

 XE "specifying user interface content directories" 
By default, the Simulator presents the user interface included in the file BrowserData.image in the main Simulator directory. BrowserData.image is a compressed file system image built with the Microsoft TV tool, BuildFSImage. This tool is called when you build images with the Microsoft TV tool, bldtvpak. For details on using these tools to build Microsoft TV user interface images, see User Interface 

The Simulator lets you view custom user interfaces by specifying an ordered set of Browser Data search paths. When the Simulator looks for a specific file, it searches for it in each specified path and renders the first instance of the file it encounters. 

Your custom source directory can contain any portion of the Microsoft TV user interface source files that you want to modify as long as they are organized in the directory structure in which the Microsoft TV Browser expects. For details on the location and organization of the Microsoft TV user interface files, see the User Interface
To add a directory to the Browser Data search path:

41. Choose Browser Data… from the Tools->Browser menu. Initially, the Browser Data search path list contains the main Microsoft TV Simulator program directory, which contains the BrowserData.image file.
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42. Check the Search local file system check box. The Add… button becomes active.

43. To add a directory, click the Add… button. The Browse for Folder dialog box appears.

44. Navigate your local file system to the directory that contains your custom content and click OK. The directory is appended to the Browser Data list.

Your content must be organized in the same way as the Microsoft TV user interface files. For example, if you installed Microsoft TV in C:\ on the same system, you can configure the Simulator to use the user interface source files by adding the following directory to the Browser Data search path:

C:\Wince212\PUBLIC\tvpak_browser\Content\


BrowserData\USA\common\PUBLIC\

This path points the Simulator to all files in the specified directory. If you want to test a single custom page, it must reside in the same directory structure as the standard user interface files. For example to test a custom version of the Service Options page, ServiceOptions.html, place it in c:\MyUIFiles\Web\ConnectSetup and add c:\MyUIFiles to the Browser Data search path. 

For details on the Microsoft TV user interface source files, see the User Interface book of this Help system.

45. If the list contains other entries, specify the search order by selecting entries, and moving them up and down in the list with the Move Up and Move Down buttons.

If you want the Simulator to look for user interface files in c:\MyUIFiles before looking in the Microsoft TV user interface source files, add entries to the Browser Data as follows:
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46. When you are done adding entries to the Browser Data dialog, click OK. Your new search path takes effect the next time you start the Simulator or reset it by choosing a new service from the Service menu. 

Note   The Simulator reloads the XML Configuration file when it restarts, but not when it resets. If you want to test the Simulator with a modified Application Configuration file, you must add the appropriate directory to the Browser Data search path, and then restart the Simulator.

Translating Partition Names XE "partitions: translating names" 

 XE "translating partition names" 
The Microsoft TV user interface source files are designed to work when installed on Microsoft TV-based set-top boxes, which means that the local file system follows Windows CE conventions. For example, URLs for files on the set-top box begin with a partition name instead of a drive letter. If you use the Simulator to test custom user interface files that reside in the same partition as the standard user interface files, the Simulator will have no trouble locating them. 

If you add a new application to the Microsoft TV user interface, however, its source files are likely to reside in a new partition. 

While a Microsoft TV-based set-top box understands partition names in the XML Configuration file, the Simulator, which runs on Windows NT, does not. You can configure the Simulator to translate Windows CE partition names into local directory names (under file://disk/) by defining an Application Store directory. 

The Application Store is a directory that contains subdirectories with the same names as the partitions in which you plan to install new applications. For example, if you plan to install two games on Microsoft TV-based set-top boxes in partitions named file://disk/game1 and file://disk/game2, when you add links to the user interface, your URLs should be:

· file://disk/game1/tvhtmls/games.html

· file://disk/game2/tvhtmls/games.html

To test these applications on the Simulator, you must put the application files in directories named game1 and game2 in the same directory, which you can then define as the Application Store. 

To define the Application Store directory:

47. Choose Application Store… from the Tools directory. The Application Store dialog box appears. 

48. Specify the Application Store directory by typing in the full local path or by clicking Browse… and navigating to the desired directory. For example, if your application directories reside in c:\MyPartitions, the Application Store dialog should look as follows:
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49. Click OK. The Simulator looks for partitions in the Application Store directory the next time it restarts or resets.

Installing Your Applications XE "application: integrating" 

 XE "integrating your application" 
Use the Simulator to test various functions that your application must accommodate as if a user were using your application in the Microsoft® TV Browser. 

To test a custom application with the Simulator you must first integrate the application into the Simulator.

Your application must be a Win32 Control compiled for Windows NT.  You must build, install, and run your control for Win32 to integrate it into the Microsoft TV Simulator. The following is an example of integrating the CardsATL30CE application (solitaire) into the Microsoft TV Simulator. Use this procedure, but modify it for your specific application that you want to integrate.

To integrate an application 

50. Start Visual Studio 6.0. 

51. Open the workspace nt.dsw. 

52. Open the file SolitaireX.h. 

53. Manually edit the RESOURCEPREFIX line to match your development environment's paths.

You must manually edit this path to match your development environment.

#define RESOURCEPREFIX(X) "D:\\2.12\\PUBLIC\\tvpak_core\\sdk\\samples\\CardsATL30CE\\data\\" ## X

54. Choose the menu item Build : Build CardsATL30CE.dll.

55. Open a command shell window. 

56. Create a directory for application partitions (for example, D:\Applications).

57. Create a subdirectory for the Solitaire application partition (for example, D:\Applications\Solitaire).

58. Change your working directory to the Debug or Release directory, depending upon whether you built a debug or release version of the control. 

59. Copy the file CardsATL30CE.dll to the Solitaire partition. For example, to copy the files to the D:\Applications\Solitaire directory:

> copy CardsATL30CE.dll D:\Applications\Solitaire
60. Copy all the files in the Cards\ATL30CE\data directory into the Solitaire partition directory. For example, to copy the data directory to D:\Applications\Solitaire:

> cd D:\2.12\PUBLIC\tvpak_core\sdk\samples\CardsATL30CE
> copy data\*.* D:\Applications\Solitaire
61. Change the working directory to the directory representing Solitaire partition. For example, to change to D:\Applications\Solitaire:

> cd D:\Applications\Solitaire
62. Use the regsvr32 command to register the control: 

regsvr32 CardsATL30CE.dll 

63. Add a link to the following URL: 

file://disk/Solitaire/Launch.htm

64. Launch Microsoft TV Simulator. 

65. Choose BrowserData from the Tools menu and then add the Public user interface directory to the BrowserData list. For details on using the BrowserData tool, see "Specifying User Interface Content Directories."

66. Choose Application Store from the Tools menu and then specify the application partitions directory (for example, D:\Applications).

67. Exit the Simulator, then start it again to reload the XML configuration file. Locate the new Solitaire button.

68. Click on the Solitaire button. Your application is activated and the Simulator loads your entry page. 

69. Click the Play Solitaire button. You can use any of the Simulator commands to test your application.

If at this point you do not see the Solitaire game, check that you defined the RESOURECPREFIX macro correctly in step 4, and then repeat steps 4 through 19 with the appropriate modifications for your application.

Note   The colors of the CardsATL30CE control appear much darker than normal. Select Gamma Correction from the Tools->Display menu to adjust the brightness.

Accessing Simulator Commands XE "Simulator commands" 
Using commands in the Microsoft® TV Simulator involves accessing commands through the menu bar, toolbar, or virtual remote control.

The menu bar is the primary method for selecting operations to perform. It provides several menus, each with one or more options you can select. The menu bar provides many more options than are available using the toolbar, but most options on the toolbar have a corresponding menu bar option.

How to use each command is described in later sections.

To access the operations supported under each menu

70. Click one of the menus.

Operations that have been grayed out are disabled and are not available in the Browser’s current mode (TV or Web). If the desired operation is disabled, you must change to the other mode before it becomes available for execution.

71. Click the operation in the drop-down list.

The Microsoft TV Simulator performs the selected operation. In some cases a dialog box appropriate for the selected operation appears and you will need to provide additional information before the operation can be executed.

The Microsoft TV Simulator provides icons for selecting operations to perform. The toolbar provides a subset of menu bar options and remote control functions. 

	Icon
	Menu Bar Equivalent
	Description

	[image: image10.bmp]
	None
	Hyperlinks to the internal developer Web site, http://developer.webtv.net

	[image: image11.bmp]
	View>Browser>Home
	Hyperlinks to the TV Home page when in TV mode and the Web Home page when in Web mode

	[image: image12.bmp]
	View>Browser>Back
	Sequences backward through Browser screens

	[image: image13.bmp]
	View>Browser>Reload
	Refreshes the display in the Browser window

	[image: image14.bmp]
	None
	Scrolls down through the Browser content

	[image: image15.bmp]
	None
	Scrolls up through the Browser content

	[image: image16.bmp]
	None
	Increments the current channel selection.

	[image: image17.bmp]
	None
	Decrements the current channel selection.

	[image: image18.bmp]
	File>Open
	Opens a file selected from the local machine or network

	[image: image19.bmp]
	File>Save Browser Contents As
	Saves the Browser content in a file and format that you select. You can save the Browser content in any of the following formats:

· HTML

· Page bitmap

· Screen shot

If you have previously saved the Browser content, it saves it in the same file and format as the last time. 

	[image: image20.bmp]
	View>HTML Source
	Opens window with the HTML source code for the current page.


To access the operations supported by the Toolbar

· Click the toolbar buttons that corresponds to the operation you want to perform.

The Microsoft TV Simulator performs the selected operation. In some cases a dialog box appropriate for the selected operation appears and you will need to provide additional information before the operation can be executed.

Testing Browser Menu Options XE "browser: testing menu options" 

 XE "testing: browser menu options" 
The Microsoft® TV Simulator provides a Browser submenu under the View menu to provide Browser controls similar to those found on Web browsers. From the View->Browser menu, you can:

· Navigate in the Browser

· View HTML source

· Test Backlist function

· Test HTML elements

· Use the virtual remote control

Navigate in the Browser XE "browser: navigating in" 

 XE "navigating in the browser" 
To navigate in the Browser

72. Select a navigational option from the View->Browser menu.

You can select any of the following options to navigate in the Browser Window.  Some options are available only while in TV mode and others only while in Web mode. 

	Option
	Shortcut Key
	Description

	Home
	Ctrl+H
	Hyperlinks to the Home URL

	Go Back
	Ctrl+B
	Goes to the previously visited HTML page

	Recent
	
	Displays a list of URLs that were visited during this session. The following is an example:
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	View
	
	Toggles between TV Home and Web Home

	Options
	
	Shows the options for the current mode 

For TV mode, the following options appear at the bottom of the Browser Window:

For Web mode, the following options appear at the bottom of the Browser Window:



	
	
	

	
	
	

	
	
	

	Reload
	Ctrl+R
	Refreshes the content currently appearing in the Browser Window


View HTML Source XE "HTML Source: viewing" 

 XE "viewing HTML Source" 
You can view the HTML source of any page displayed in the Browser Window.

To view HTML source

· Select View HTML Source from the View menu.

Another window appears showing the HTML source of the current page in the Browser Window. The following is an example of HTML source for the Service Options page:
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Note   You cannot edit the HTML source from this window. If you need to edit the HTML source, you must open the source using a valid editor.

Test Backlist Function XE "backlist function" 

 XE "checking: backlist function" 
You can confirm that your application properly tracks the sequence of windows that have displayed in the Browser Window. As each page displays in the Browser Window, the Simulator places an entry in the Backlist. The Backlist can contain as many entries as you want to test your application. Your application should be able to go back to each of the URLs in the sequence that they are listed in the Backlist.

To test the Backlist function

73. Select Backlist Window from the View menu.

The Backlist window with content similar to the following appears:
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74. Sequence through the pages in your application.

As you sequence through the pages, an entry is added to the Backlist. 

75. Confirm that your application sequences backward through the application pages in the order that they are listed in the Backlist window.

Test HTML Elements XE "HTML elements" 

 XE "checking: HTML elements" 
The Simulator provides the Displayables window that lists all of the HTML elements on a page in tree-list format. The information provided in the Displayables windowchecks HTML elements on your application pages and their hierarchical relationship to one another. If you double-click an HTML element in the Displayables window, the Simulator flashes a rectangle showing the location of the element in the Browser Window. It provides two options:

· Auto-Expand Tree

· Track Mouse in Browser Window

The Auto-Expand Tree option automatically expands the tree list each time a new page appears in the Browser Window. This option is enabled by default. However, to disable this option, click the check box so that the check mark no longer appears.

The Track Mouse in Browser Window option maps the HTML element in the Displayables window to the content in the Browser Window. This option is disabled by default. If you enable this option, you can pass the mouse over content in the Browser Window causing the Simulator to scroll to the corresponding element in the Displayables window. If the cell is scrolled off the screen when the user double clicks an element in the Browser Window, the Simulator automatically scrolls the Displayables window until the cell is in view and highlights it.

Note   The Simulator must be in Web mode to activate this feature.

To test HTML elements

76. Be sure the Browser Window is in Web mode.

77. Select Displayables Window from the View menu.

The Displayables Window with content similar to the following appears:
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78. Select the check box option you want enabled. 

79. Select an HTML element from the Displayables window or move the mouse in the Browser Window.

Use the Virtual Remote Control XE "remote control: using in Simulator" 
The Simulator provides a virtual remote control to test your application for accepting commands through the remote control. The virtual remote control provides standard remote control functions.

To use the virtual remote control

80. Select Remote Control from the View menu.

The virtual remote control appears.
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81. Click the remote control buttons to test your application and its responsiveness to the remote control commands.

Note   To hide the remote control, choose Remote Control from the View menu. 

Managing Files XE "files: managing" 

 XE "managing files" 
The Microsoft® TV Simulator helps you manage files by giving you fast access to the files and URLs that you have already created. Files can be text files, HTML files, or image files.

Opening Files XE "files: opening" 

 XE "opening files" 
You can open any file on your Windows NT machine or in your Network Neighborhood if your machine is connected to a network. 

To open a file

82. Select Open File… from the File menu.

The Open dialog box appears.

83. In the Look In field, select the directory in which the file you want to open is located. 

The file can be located on your local machine or on a machine in your Network Neighborhood.

84. Enter the name of the file you want to open in the File name field.

85. Select the type of file you want to open from the File of Type drop-down list.

86. Click Open.

Opening URLs XE "URLS: opening" 

 XE "opening URLs" 
To open a URL

87. Select Open URL… from the File menu.

The Open URL dialog box appears.
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88. Enter the URL you want to open. 

The URL can be any valid URL accessible through protocols such as FILE and HTTP.

89. Click OK.

The selected URL appears in the Browser Window.

Saving Files  XE "files: saving" 

 XE "saving files" 
You can save changes to an existing file with the Save Browser Content command. You can save a new file or an existing file under a new name with the Save Browser Content As command. This command is useful when you want to maintain the original file without changes but also want a copy of the file with your changes.

To save an existing file

· Select Save Browser Content… from the File menu.

The file is saved in the same location.

To save a new file or an existing file under a new name:

90. Select Save Browser Contents As… from the File menu.

91. Enter a file name.

92. Select a type of file.

You can save the file as one of the following:

· HTML

· Page bit map

· Screen shot

93. Click OK. 

Printing from the Simulator XE "Simulator: printing from" 

 XE "printing from the Simulator" 
The Simulator provides standard printing functions for the contents of the Browser window. You can print the entire HTML page or only the current screen.

To print from the Simulator

94. Click one of the print options from the File menu. 

You can select from the following options:

· Print option to print the contents to a selected printer

· Print Preview option to view the printed output on the screen

· Print Setup option to set up the format of the printed output

A dialog box appears for each of these options.

95. Enter the appropriate information at the dialog box.

96. Click OK.

Using the Clipboard XE "Clipboard" 

 XE "using the Clipboard" 
To use the Clipboard 

97. Select the information that you want to cut or copy.

98. Select the option from the Edit menu or the corresponding shortcut key that suits your need. 

The following table lists and briefly describes the options and shortcut keys available.

	Option
	Shortcut key
	Description

	Copy Browser ScreenShot
	Ctrl+C
	Copies the image currently displayed in the Browser to the Clipboard. The Browser Window must be active.

	Copy Source Selection
	Ctrl+C
	Copies the selection from the View HTML Source window to the Clipboard. Text must be selected in the View HTML Source window.

	Copy URL
	Ctrl+C
	Copies the selected text into the Clipboard while leaving it in its original location in the file. From the Clipboard, you can move it to another location in the same file or to another file. URL in the toolbar must be selected.

	Cut URL
	Ctrl+X
	 Cuts the selected text from the file and places it into the Clipboard. From the Clipboard, you can move it to another location in the same file or to another file. URL in the toolbar must be selected.

	Paste URL
	Ctrl+Y
	Pastes text from the Clipboard to a location in the file pointed to by the cursor. URL in the toolbar must be selected.


Selecting Frequently Used URLs XE "URLs: selecting frequently used" 

 XE "frequently used URLs: selecting" 
The Simulator provides a quick way to access URLs defined in your Internet Explorer (IE) browser as favorite or frequently used URLs. You cannot add or delete URLs from this list using the Simulator; you must configure the Favorites list through IE. If you do not have any favorite URLs defined in IE, none will be listed in the Microsoft TV Simulator.

To select a favorite URL

99. Select a URL from the drop-down list under the Favorites menu.

The Microsoft TV Simulator opens the selected URL.

100. If you want to access another favorite URL, select another from the drop-down list.

Simulating Interactive TV links XE "interactive links: simulating" 

 XE "simulating interactive TV links" 
An interactive TV link is a URL and other IP-oriented information that is encoded into a broadcast signal within the Vertical Blanking Interval (VBI). When an interactive TV link is created, an icon displays on the television screen. When the user selects this icon, the URL content displays on the television in a framed area. In a real environment, the interactive TV link displays while watching TV, usually because a service sends the Interactive TV link. The Microsoft® TV Simulator simulates sending interactive TV links from a service.

Note   To simulate this feature, the Simulator must be in TV mode.

Creating an Interactive TV Link XE "interactive links: creating a single link" 

 XE "creating: an interactive TV link" 
You can create a single interactive TV link as if it were encoded in a broadcast signal. 

To create a single interactive TV link

101. Select Link Creator Window from the View menu.

The Interactive TV Link Creator window appears:
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102. Enter the URL that you want displayed on the television when the Go Interactive icon is pressed.

You must specify the entire URL including the protocol, for example, http://www.microsoft.com. This is a required field.

103. Select a Link Type from the drop-down list.

The link types are only to help you categorize the links. It provides no distinct functionality for the Link Type you have selected. This is an optional field.

104. Enter a Display Name.

The display name is the name that you want to appear on the television to identify the interactive TV link. It can be up to 32 characters in length. This field is required.

105. Enter a Script Trigger. 

A script trigger activates actions on the Web page that the interactive TV link references. This value specifies a function sent to the target Web page that the Browser executes after the Web page is opened. If the page is currently being displayed, the function executes immediately. This field is optional. 

106. Enter an expiration time.

An expiration time defines when an interactive TV link expires and can no longer be accessed. The format of the time conforms to ISO-8601 and is relative to Greenwich Mean Time (GMT). Be sure to select the correct time zone.

Note   Typically, once you create an interactive TV link, it appears on the Browser Window. You can access this link by clicking the Go Interactive button. However, if you do not do this within 15 seconds the link will disappear. You can then only access the interactive TV link by clicking the Options button on the remote control, and selecting the Go Interactive button. The Options button maintains this trigger until either the expiration time elapses or another link is triggered. Only the last interactive TV link triggered can be accessed.
107. Click the Web or TV radio button.

If you click the Web button, the Browser displays the page as a normal Web page. If you click the TV button, the Browser formats the content for TV viewing.

108. Check the Generated Link field to confirm the link that you want generated.

Note   If you want to copy this link into the Clipboard, right click, and then select Copy.

109. Click Trigger in Browser to create the interactive TV link and cause it to display in the Browser Window.

An interactive TV link similar to the following appears at the bottom of the Browser Window.
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Creating Batched Interactive TV Links XE "interactive links: creating batched links" 

 XE "batched interactive links" 

 XE "creating: batched interactive TV links" 
You can create batched interactive TV links as if they were encoded in a broadcast signal. Batched interactive TV links are a list of interactive TV links scheduled to appear at a specific time. If the time elapses before the user activates the interactive TV link, the interactive TV link expires and can no longer be activated.

To test batched interactive TV links

110. Select Link Sequencer Window from the View menu.

The Interactive TV Link Sequencer window appears:
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111. Click Add.

The Edit Interactive TV Link window appears:
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112. Enter the URL that you want displayed on the television when the Go Interactive icon is pressed.

You must specify the entire URL including the protocol, for example, http://www.microsoft.com. This is a required field.

113. Select a Link Type from the drop-down list.

This is an optional field. The link types are only to help you categorize the links. It provides no distinct functionality for the Link Type you have selected.  

114. Enter a Display Name.

The display name is the name that you want to appear on the television to identify the interactive TV link. It can be up to 32 characters in length. This field is required.

115. Enter a Script Trigger. 

A script trigger activates actions on the Web page that the interactive TV link references. This value specifies a function sent to the target Web page that the Browser executes after the Web page is opened. If the page is currently being displayed, the function executes immediately. This field is optional.  

116. Click the Web or TV radio button.

If you click the Web button, the Browser displays the page as a normal Web page. If you click the TV button, the Browser formats the content for TV viewing.

117. Provide a Trigger Time Offset for the time you want the interactive TV link to display.

This time is offset from the time you press the play button. This is a required field.

118. Click OK.

119. Add as many interactive TV links as you want.

Once you have added an interactive TV link you can edit, delete, and duplicate it to create other interactive TV links. The interactive TV links must have different time offsets to function properly.

120. Click the Play button to start the batched interactive TV links, and the Stop button to stop the processing.

To save batched interactive TV links

You can save batched links in a trigger (.trg) file. 

121. Click the Save button to save the current batched list of interactive TV links to a trigger file.

The Save As window appears:
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122. Enter a file name and the directory you want it saved in.

123. Click Save.

You can load the trigger file anytime later without recreating the entire list of batched interactive TV links.

To load trigger files

124. Click the Load button on the Interactive Link Sequencer window.

The Open window appears:
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125. Select the trigger file you want to load.

126. Click Open.

127. You can now load this .trg file any time. 

The trigger file is loaded into the Interactive Link Sequencer window. You can run the same batched links or you can modify or delete them.

Debugging Your Application XE "application: debugging" 

 XE "debugging your application" 
The Microsoft® TV Simulator provides the Message window to help you debug your application. The Simulator logs all messages produced using the Simulator. 

To view the message log

128. Click Message Window from the View menu.

129. The Message Window appears with content similar to the following:
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130. Check the Message log to debug your application.
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